The launch of the Final Fantasy MMO, Final Fantasy 14 (written Final Fantasy XIV) was highly anticipated by everybody on this planet, but unfortunately for Square Enix, the game is plagued by problems like game crashes and freezes, to mention just the biggest of them. In this article we’ll try to find out how to fix Final Fantasy 14 crashes and freezes in order to help you get the most out of the game!

First of all, before trying any of the fixes, make sure that your system meets the minimum system requirements for Final Fantasy 14 – lower specs might be the reason of the crashes and freezes. If everything is OK here, here’s how to try and fix the problems:

I. FFXXIV not running or crashing fix from the tech support:

“1. Start the game in Window mode
Start Menu > All Programs > SQUARE ENIX > FINAL FANTASY XIV > FINAL FANTASY XIV Config
General > Video Settings > Display Mode > Windowed

2. Decrease the texture quality
Start Menu > All Programs > SQUARE ENIX > FINAL FANTASY XIV > FINAL FANTASY XIV Config
General > Graphics >
[Texture Quality] > Low
[Texture Quality Filter] > Lowest

3. Stop programs running in the background
Certain programs may prevent FINAL FANTASY XIV from running properly. Users may stop certain programs that are running in the background at their own discretion.

4. Update graphic drivers
Please visit the official website for your current graphics card for more information on how to update the graphic drivers.

5. Reinstall FINAL FANTASY 14
Certain data may have been corrupt during the installation process. Please uninstall FINAL FANTASY XIV, and then reinstall it.”

II. Update your graphics card drivers, close all the running applications in the background (including antivirus software) and try running the game again! Also, if you try running the game as ADMIN might help.

Hopefully any of these fixes will help you solve the Final Fantasy 14 crashes and freezes. Good luck and don’t forget to share with us any possible solution you can think of!

3 COMMENTS

  1. Have tried everthing on SE support site and nothing worked. The game runned perfectly bedore the update yesterday. Mailed SE support and hope they can resolve this soon. Would be a deal bewaker if this takes to long :(

  2. umm… i just installed it for the first time and as soon as i go to click play it says the program isn’t responding… and i have tried all of this… and it still won’t work… and my comp meets all the required stuff to play… any other help i can get with this would be much appreciated! thank you.

    • Try SE support, They solved my problem within a day! My problem was that my sound quality setting was 2 high for Vista 64 bit. Gl with it!

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.